Concordium Mobile wallet installation problem

‘Your device is not compitable with this version’ is shown at the time of installation.

The mobile wallet should support iOS 13 or later, and Android 8 or later. What device and operating system are you using?