Is there an issue with 'cargo condordium init'?

Hi, it looks like running cargo condordium init has an issue with the latest version of Rust?

It gives the error message:

“Error: Required cargo-generate version not met. Required: >=0.16.0, <0.18.0 was: 0.18.1
Error: Could not create a new Concordium smart contract project.”

or maybe I have done something wrong here?

Hi Stefan,

We’ve only tested that our smart contract templates work with cargo-generate versions 0.16 and 0.17.
So the issue is that you are using cargo-generate 0.18.1.

I will create an internal task about testing our templates with 0.18.*, thanks for letting us know!

Until then you can install an older version of cargo-generate with:

cargo install --version ^0.16 cargo-generate

and then run

cargo concordium init

again. (I couldn’t install ^0.17 on my machine due to a compiler error, but 0.16 worked. You can try with 0.17 first if you prefer.)

Best regards,

1 Like

This is fixed now, and we support cargo-generate 0.18.* as well.