Ledger Nano S install - Broken certificate chain - loading from user key

I followed the instructions for installing the Ledger app.

When I came to


It will not install the app, but rather

Broken certificate chain - loading from user key
Traceback (most recent call last):
File “C:\Program Files\WindowsApps\PythonSoftwareFoundation.Python.3.9_3.9.1520.0_x64__qbz5n2kfra8p0\lib\runpy.py”, line 197, in _run_module_as_main
return _run_code(code, main_globals, None,
File “C:\Program Files\WindowsApps\PythonSoftwareFoundation.Python.3.9_3.9.1520.0_x64__qbz5n2kfra8p0\lib\runpy.py”, line 87, in _run_code
exec(code, run_globals)
File “C:\Users\brian\AppData\Local\Packages\PythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0\LocalCache\local-packages\Python39\site-packages\ledgerblue\loadApp.py”, line 283, in
loader.createApp(code_length, args.dataSize, paramsSize, args.appFlags, args.bootAddr|1)
File “C:\Users\brian\AppData\Local\Packages\PythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0\LocalCache\local-packages\Python39\site-packages\ledgerblue\hexLoader.py”, line 359, in createApp
self.exchange(self.cla, 0x00, 0x00, 0x00, data)
File “C:\Users\brian\AppData\Local\Packages\PythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0\LocalCache\local-packages\Python39\site-packages\ledgerblue\hexLoader.py”, line 201, in exchange
return self.scpUnwrap(bytes(self.card.exchange(apdu)))
File “C:\Users\brian\AppData\Local\Packages\PythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0\LocalCache\local-packages\Python39\site-packages\ledgerblue\comm.py”, line 145, in exchange
raise CommException(“Invalid status %04x (%s)” % (sw, possibleCause), sw, response)
ledgerblue.commException.CommException: Exception : Invalid status 5103 (Unknown reason)

Welcome to the Concordium Discourse!

There are a few common reasons that installing the Concordium Ledger app can fail. Here is a checklist:

  • Did you successfully install the custom certificate?
  • Have you made sure to close all applications that might connect to the Ledger, such as Ledger Live and Concordium Desktop Wallet?
  • When you connected the Ledger to your PC, did you hold down the right button until recovery appears on the display? (This is needed when installing the certificate, but not the app itself.)
  • Did you extract all of the files from the ZIP archive before running install.bat?
  • Use either the command prompt or powershell to run the loadcertificate.bat and install.bat, and not WSL.

(It looks like the last of these does not apply in your case, at least.)

I hope at least one of these will help.

– Thomas

Alas, I did all that.

Except that I ran PowerShell in a Windows Terminal (yes, good old Windows, not WSL).

I tried to run it in Powershell 7 (x64) as an admin, just to try something. And then I booted (it is Windows, after all), and tried again.

Same result :thinking:

Another couple of things to check:

  • Is the firmware updated to 2.0.0? (You can check on the settings menu in the device, or with Ledger Live, which will also let you update it.)
  • Do you have any other apps installed on the Ledger? (The Nano S has limited capacity, so potentially this could be a problem.)

What do you see on the Ledger itself during this process? I presume you get past the Allow unsafe manager prompt?

– Thomas

Thanks, that was it - too little room on the device. There was only two apps, but after uninstalling them, I managed to install the Concordium app.

Now to the next challenge,

Unable to create identity

Missing cryptographic parameters, please connect to a node to load these.

Apparently, I need to run my own node.

I would expect Concordium to provide a few nodes, now that the mainnet has been released?

1 Like

Excellent! I’ll close this thread to keep it on topic, but for your next challenge this might help.