Anonymity Revokers

I tried creating a new account for my company identity. The identity was created using the old command line tool. I already created one account successfully. Now when I try again to create another account I get the error:

Error: Transaction not accepted by the baker: GRPC response with status 'INVALID_ARGUMENT': GRPC error: The credential deployment contained invalid anonymity revokers.

Any pointers? Do I need an updated ars.json file maybe?

Is this on mainnet or testnet?

Are you using the new tool now to create the account?

It‘s mainnet. I used the old cli tool because I started the whole process with the cli tool.

Hello wackazong,

To create a Mainnet Company ID, use our new tool. Check out the documentation for detailed steps: Company identity creation — Concordium documentation

Download the tool here: Downloads — Concordium documentation

If you have any question, lt me know.

Best, Zoltán

1 Like

Ok, I used the id-object.json with the new tool and after some errors it worked. Thanks.