Cannot deploy with error "account or block not found"

What I did: follow the docs (today) to install the toolchain, run a testnet node in docker (name is ibexus), create an identity and an account (3fi5egw6TVx7eejp53SsWhUBC3CntpEBDWn2MThSWQZK719U4d) and generate a template contract. I built successfully and now I want to deploy. The command

concordium-client module deploy target/concordium/wasm32-unknown-unknown/release/concordium_test.wasm.v1 --sender alice --grpc-ip --grpc-port 20001

Gives me

Error: A GRPC error occurred: GRPC error: account or block not found.

I created a new testnet identity and account and added it to concordium-cli and it worked.

1 Like

Do you mean that your problem is resolved? Or that the import worked?

In the latter case, the likely cause of your problem of “account or block not found” is that your node was not caught up.

Hey, thanks for coming back to this.

The import worked and also the problem was resolved. It could very well be that the node did not yet catch up.

1 Like