Issues while deploying concordium to ethereum bridge

Hey guys
I want to deply ethccd relayer
But for that I have to build and run the docker image from
and I have build the image with all envs and tried to run it on docker but it exited without errors also logs of this container were empty

Can anyone help me out with it

It is a bit unclear to me what exactly you have tried and what leads to the error.

Can you please list the commands you have tried and the outcomes you get?

Hey @abizjak I have cloned the repo above and then built an docker image but when I am trying to run the image it doesn’t shows anything

And I have check docker containers logs but they are also clean

Right, but until you tell me exactly what you have done it’s hard for me to know what the problem is.

The docker image that is built does not specify any entrypoint. You need to specify what you want to run.

What did you do?

Well I don’t know anything what to do I want someone to explain what I need exactly to run it

It’s a bit unclear what you would like to run.

You need to run a few components

  • deploy concordium contracts
  • deploy ethereum contracts
  • set up the relayer and the API server
  • set up the frontend

We don’t generally provide support for setting up this bridge, but can you please list commands that you are attempting to run.

Well thanks I have started process as you sent me I have deployed ethereum contracts but when I am deploying bridgemanager contract of concordium it gives me the following error

And for CIS2Bridgeable token can you tell me what are the parameters that I have to send to init that contract

Once again Thanks @abizjak

what do you see when you run concordium-client contract show <index> ?

I don’t have index of contract because it’s not initialized yet

@by-ccd Above error is when I am initializing the contract after deployment

Hey, @afzalimdad9 I meant that for your other issue but ah I see now, that you are getting that while calling the init function. Please see other post.