Piggybank tutorial -- yarn command and incompatible module

I have been going through the piggy bank tutorial and now at the 4th part setting up a frontend. However after having cloned and running the commands:

yarn start

I get following errors:
On yarn i get:
error @concordium/common-sdk@6.2.0: The engine “node” is incompatible with this module. Expected version “>=14.16.0”. Got “10.19.0”
and on yarn start:
/bin/sh: 1: react-scripts: not found
error Command failed with exit code 127.
Last error I assume is due to the incompatibility in yarn ? :slight_smile:

It is not clear to me which module that is outdated and how to update it?

Regarding the first error, your nodejs version is too old. You need to install at least version 14.16. See here Download | Node.js for the variety of ways that can be done.

What platform are you on that you have such an old node version?

That did the trick! Thanks!

I am working locally so changing version is no issue :slight_smile:

1 Like