Starting node on the main network

Hello everyone
I couldn’t get the node to run properly on the mainnet

I am currently trying to deploy a smart contract using the standard command:
concordium-client module deploy cis2_nft.wasm.v1 --sender SENDER --name cis2_nft --grpc-ip IP --grpc-port 10000

After entering the command, it waits for 30-60 seconds, after which I get the following response concordium-client: user error (Cannot establish connection to GRPC endpoint.)

At the same time, the same command, only with port 10001, is executed successfully.

I conclude that only the node for testnet works for me, but the node for mainnet does not work. The question is how to run it correctly?

Can you explain the steps you used to set up the mainnet node? Which platform are you running on?

mainnet node installed on ubuntu server.
the installation was carried out according to the documentation, as well as testnet node

What IP are you using? Note that the mainnet node will take a lot longer to start than the testnet node. Does the query fail also after, e.g,. 10min, or after the node has peers?

Can you post the logs from node startup?

no, I use the ip of the remote server where the testnet and mainnet nodes are located

Since the mainnet node was launched on January 13, it might not have enough time to deploy?

Can you please tell me what logs are you talking about and where are they located? we are talking about the results of running this command sudo systemctl status concordium-mainnet-node.service

Oh I see.

Then are you sure you have port 10000 also accessible and not blocked by the firewall?

I am talking about the node logs.

You can get them by running

sudo journalct -u concordium-mainnet-node --since '2h ago'

where you can adjust the 2h ago to an appropriate timeline. In those logs there should be something like Starting up concordium .... That’s when the node is starting. If you can show around 50 lines after that we can see what happens during startup.

10000 as far as I understand is the standard port for grpc

requested data for the past 1 minute, and just ran his command
I get these logs:

Your node is clearly running. I just wanted to see the logs from startup since details of the configuration are printed then.

Yes, the mainnet node should be listening there. But if you are querying it from outside the VM then you might have to configure firewall, port forwarding or other things. Have you done none of this for 10001?

1 Like

Yes, for port 10001 I did nothing

Just launched the node, and immediately everything worked

How can I check if specific ports are open?

So I cannot really help in debugging this fully since I don’t know your network setup.

However you can do the following

  • check that the node is listening on the correct port for grpc queries. You can do this by running concordium-client from the VM to remove the network/firewall issue.
  • To query the node from outside the grpc server must be listening on (well technically it can be listening on another interface as well, but let’s try with this). This is the default so unless you’ve changed it it should already be set. However you can check this by running
sudo systemctl cat concordium-mainnet-node

This should print the entire configuration which should contain


Can you check that that is the case?


I solved the problem for myself by deploying the concordium-client directly on the server. Thanks for all the tips)

1 Like


I solved the problem for myself by deploying the concordium-client directly on the server. Thanks for all the tips)

1 Like