Error when trying to install ledger concordium wallet

I followed the steps from Set up the Ledger Nano S and install the Concordium Ledger App — Concordium documentation but when I try to install the certificate (using loadcertificate.bat) or try to install the wallet (install.bat) I receive the following error. This error is from install.bat, but when I run loadcertificate.bat in recovery mode, I receive the same error.
Any help would be appreciated!

Are you running the 2.1.0 version of the Ledger firmware? You can check this in Ledger Live on the “Manager” page. Unfortunately, this seems to be a problem on devices running this version, and we are currently investigating the issue.

Yes, I’m running the 2.1.0 version of the firmware. I guess that is irriversable? (should be anyway. ;-))
I certainly hope there will be a solution before December 8th… :wink: I’d like to join the Airdrop…

I believe it is irreversible, yes. I hope we will have a solution soon, but cannot say for sure when it will be. In the meantime, you could use the mobile wallet. Accounts created on the mobile wallet can’t be moved to the desktop wallet or vice-versa, but you can of course transfer CCD from a mobile wallet account to a desktop wallet account.

Thanks for the tip, I’ll try that! In the meantime I keep an eye out for a solution for the ledger nano S with firmware 2.1.0!

I get a similar message with Invalid status 5214 in the end.

Fw 2.1.0

Hi oVgnhBew,

Error 5214 means that the certificate is already installed.
You do not need to reinstall the certificate in order for you to update the Concordium app on the ledger.

Best regards,

1 Like

Just a general question regarding to this issue with firmware 2.1.0; if you’re able to solve it; will you let me/us know here or are there other channels I have to keep an eye on?

You can generally rely on new releases being announced in the Releases category here. (There will almost certainly be a new release of the ledger app to fix the 2.1.0 issue.) I’ll try to remember to post on this thread when we have a solution.

1 Like

We now have a release for Ledger 2.1.0: Downloads — Concordium documentation

Thanks for the update, I’ll have a look!