Ledger Nano S - Broken Certificate Chain - loading from user key (Mac OS X)

Hi There,

I am facing issues with the installation of the Concordium app for Ledger Nano S. During installation of the certificate i get the following error “Broken certificate chain - loading from user key”.

I am running the following specs:

  • MacOS Mojave
  • Python 3.9.0

I have tried the following:

  • Reinstalling python framework from scratch
  • Reinstalled Ledger Nano S (reset)
  • Removed all apps from Ledger Nano S

Thanks for your support and looking forward to your reply.

Brief update - after few more attempts it suddenly worked (have not changed anything) - i tried holding the right bottom longer (for about 5 seconds) before reconnecting the usb cable and enabling recovery mode - not sure if this did the trick.

I still got the broken certificate error - but, this time the Concordium text to trust the certificate showed up. After that i was also able to install the Concordium app succesfully (note that here i still got the “Broken certificate chain - loading from user key” error as well).

1 Like

Hi @pepelepew.

It sounds great that you managed to get it to work! To install the certificate it is necessary to have the device in recovery mode, which is achieved by holding down the right bottom until the screen shows Recovery. My best guess is that the device was not actually in recovery mode for the first few attempts you made, but I cannot be certain. It could also be that you had an application open that tries to communicate with the Ledger, like Ledger Live or the Concordium Desktop Wallet.

The message “Broken certificate chain - loading from user key” will always be shown, and comes from the Python program we utilize and it can safely be ignored. The issue you were having is unrelated to this message.

To read more about the installation process check out Set up the Ledger Nano S and install the Concordium Ledger App — Concordium documentation.