Support for Ledger Nano X


Has there been an update regarding desktop wallet’s support for Ledger Nano X? I’m assuming no since the blueledger package for python has support only for special developer versions of the X. What I’m trying to do is become a baker. If needs be I think I’ll go ahead and purchase Nano S - it just seems wasteful given I already own Nano X.

PS I did go through installation steps, but kept getting errors when trying to install custom certificate on the device using my mac.


In order to support ledger Nano X the Concordium application must be available from Ledger Live since nano X does not support custom certificates as nano S does.
We have updated the Concordium app so it supports both nano S and nano X, however in order for you to use this it must first be approved by Ledger. When this will be depends on them (it is under review now), so we cannot give you a timeline.

thanks, I’ve actually went ahead and purchased Nano S.

Custom certificate got successfully installed but Concordium app installation on Nano S is erroring out for some reason. So far I made sure all the dependencies got installed correctly and that python3 is in my $PATH aliased to python. Also tried installing ledgerblue into a virtualenv and run from but there but same issue (ledgerblue.commException.CommException: Exception : Invalid status 570b (Unknown reason))

EDIT. Turned out Nano S firmware version 2.1.0 requires separate ledger app:
more: Error when trying to install ledger concordium wallet - #8 by s-grind
download for 2.1.0 firmware: Error when trying to install ledger concordium wallet - #8 by s-grind

The error code 570b while trying to install the app means that the certificate is not installed.

Are you sure that the certificate was successfully installed? You need to have the ledger in recovery mode for it to succeed.

Thanks for following up. Yes the certificate had been installed which I could verify by running ./ and generating the 5214 error. I was getting the 570b error when trying to run ./ from concordium-ledger-app-2.0.1-target-2.0.0 package while my Nano S has firmware 2.1.0.

When run ./ from concordium-ledger-app-2.0.3-target-2.1.0 everything worked as described in documentation.