Ubuntu Desktop wallet: Error: this.driver.Database is not a constructor

Since I change my version of Ubuntu (2304 and 2310) I have this error in the info.log file when I try to validate the new password on the desktop wallet: Error: this.driver.Database is not a constructor

I try since the 1.5.0 version, and I have the same error on each update.


Hi Phil,

The desktop wallet actually still depends on libssl 1.1, but Ubuntu 22.04 (and newer) has upgraded libssl to 3 and does not propose libssl1.1.

So until we can remove the dependency on this, you’ll have to install libssl 1.1, which you do with the following workaround:

You can force the installation of libssl1.1 by adding the ubuntu 20.04 source:

echo "deb http://security.ubuntu.com/ubuntu focal-security main" | sudo tee /etc/apt/sources.list.d/focal-security.list

sudo apt-get update
sudo apt-get install libssl1.1

Then delete the focal-security list file you just created:

sudo rm /etc/apt/sources.list.d/focal-security.list

(Taken from here apt - MongoDB Install Fails on Ubuntu 22.04 - Depends on libssl1.1 but it is not installable - Ask Ubuntu about MongoDB)

I tried this in a fresh Ubuntu 23.10 VM, and it resolved the issue for me, but if you have additional issues let me know. :smiling_face:

  • Søren

Super thank you, it works perfectly.