Wallet recovery does not seem to work?


I set up a wallet on TestNet and MainNet for the Hackathon and everything was working. I did the tasks etc.

My PC broke on Tuesday and I had to reinstall everything from scratch. I am attempting to deploy a new smart contract to play with some features but I kept getting an error about my account not existing.

I realised that I needed rocover my wallet so I used the 24 word phrase but the recovery does not seem to complete. It has hung when searching for IDs and accounts.

How should I proceed?

The system seems to hang when searching for my IDs and accounts.

Is there another way I can do this?

Hello Stefan

It should not “hang” under the recovery process, but it should take some time until the searching process goes through.

You are using a browser wallet, I guess, so the only way is to recover is to use the seed-phrases. Try to update the browser add-on, we just released the newest 0.9.8. version.

I just did a recovery with my own account. It took approximately 60 seconds.

Let me know how did it go.

You are correct that I am using a browser wallet. I left it running whilst I went for lunch and it still has not found anything.

I updated it to 0.9.8 and retried recovery - it took a few minutes but it seems to have worked for the MainNet account but not for the TestNet account.

I tried to generate a new TestNet account and it failed with "The identity issuance failed due to: “Initial location did not redirect as expected.”

1 Like

I just redid the recovery and it seems to have found the TestNet account too!

Thanks :slight_smile:

1 Like

Not sure if I am barking up the wrong tree here but I am trying to run the command:

concordium-client module deploy piggy_bank_part2.wasm.v1 --sender nossica --name piggy_bank_part2_module

But I get the error:

Error: The identifier ‘nossica’ is neither the address nor the name of an account.

I used the same wallet, same sender name etc. before my PC died and it worked. Is there some step I missing in my configuration?

To use the sender name nossica, you must import account into your config using the concordium-client config account import .export --name nossica command. First, you need to export the private key from your wallet and transfer it to your computer and then import it into your config.

After import, check your config with concordium-client config show. If you have imported the account correctly, then you should be able to use the --sender nossica flag in your commands.